问题现象
备份到Acronis存储节点失败提示“Failed to connect to the storage node”并/或“SocketError: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed”
完整错误消息示例:
| error 0x1350016: TOL: Failed to execute the command. Backing up
| line: 0x8d165e86fb8195bd
| file: d:\381\enterprise\common\tol\command\command.cpp:495
| function: Tol::anonymous-namespace'::MakeFailResult
| CommandID: 8F01AC13-F59E-4851-9204-DE1FD77E36B4
| $module: gtob_backup_command_addon_vsa64_28503
|
| error 0x9a0008: Failed to connect to the storage node.
| line: 0x9a79f20828bcb58
| file: d:\381\enterprise\mms\managers\location\impl\manager.cpp:1000
| function: LocationManagement::locationmanagerimpl::FindLocation
| IsReturnCode: 0x1
| $module: disk_bundle_vsa64_28503
|
| error 0x9a0008: Failed to connect to the storage node.
| line: 0xf9cb46cc20081f24
| file: d:\381\enterprise\file_manager\utils\connect_to_ss_lm.cpp:155
| function: `anonymous-namespace'::untrustedconnection::Establish
| ASNAddress: 10.45.32.22
| ASNPort: 0x0
| $module: disk_bundle_vsa64_28503
|
| error 0x2e50065: SocketError: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
| line: 0xe6f03fbb5004184b
| file: d:\381\enterprise\common\async_ipc\async\io_base_libevent.cpp:1220
| function: AsyncIpc::libevent::iobase::OnEvent
| Code: 0x14090086
| $module: asyncipc_vsa64_28503
问题原因
首次安装 Acronis 存储节点 (ASN) 时,它会创建代理信任的证书。因此,如果重新安装 ASN,则会颁发新证书,这会导致服务器代理连接失败,因为存储在服务器代理中的 ASN 服务器证书哈希未更新。
解决方法
要解决此问题,请手动删除受影响代理上的哈希:此解决方案适用于 Acronis Cyber Protect 15 build 27009 或更高版本。
1.找到哈希的位置:C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\raw\<-ID->
例如 C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\raw\BA429BB9-BEC6-9E80-1AD2-B278FA1CD355
2.你应该找到两个文件:“meta”和“ticket.json”。使用文本编辑器(如记事本)打开“ticket.json”文件,以验证受影响的 ASN 的名称或 IP 地址,并确认与之对应的文件夹。
(在这种情况下BA429BB9-BEC6-9E80-1AD2-B278FA1CD355)
哈希信息示例:
{
"address" : "ASN-Win-2016:hash",
"keys" : {
"15b397" : "AES-256-GCM$d50eb0$ijk7kPN7VlbZgIRf$VUCL123NkTmf0J7bZ1bNG2Q99O8kkihM1XfSmgLr5OyD+/XXXXXXXXXl0G7fB"
},
"ticket" : "AES-256-GCM$15XXXXXXXX+zcB1rObbFwiz$vt123wo3EcaIElVp6E/XXXXXXXXVKxneMbeWQAtZ/Sw",
"typename" : "ssl_cert"
}
或:
{
"address" : "192.168.10.10:hash",
"keys" : {
"d19928" : "AES-256-GCM$d50eb0$ijk7kPN7VlbZgIRf$VUCL123NkTmf0J7bZ1bNG2Q99O8kkihM1XfSmgLr5OyD+/XXXXXXXXXl0G7fB"
"AES-256-GCM$15XXXXXXXX+zcB1rObbFwiz$vt123wo3EcaIElVp6E/XXXXXXXXVKxneMbeWQAtZ/Sw", },
"ticket" :
"typename" : "ssl_cert"
}
3.出于备份目的,请将文件夹移动到其他位置(例如,移动到桌面)
4.删除包含“ticket.json”文件的文件夹,该文件包含“address”:“ASN_ADDRESS:hash”。
在我们的示例中,删除BA429BB9-BEC6-9E80-1AD2-B278FA1CD355
5.对所有受影响的代理重复上述步骤并运行备份。应创建一个具有新哈希的文件夹。
6.如果使用以下内容更新哈希后备份失败:“远程资源的指定用户名或密码 bsp://192.168.10.10/...是不正确的”。请转到设备 -> 所有设备,选择受影响的计算机,然后禁用并重新启用该计划。
更多信息
如果上述步骤未能解决问题,请联系 Acronis中文支持并参考本文。