问题现象
备份失败,并显示以下消息:
Windows error: (0x800703FA) Illegal operation attempted on a registry key that has been marked for deletion
Additional info:
------------------------
Error code: 22
Module: 309
LineInfo: 0x8D165E86FB81959B
Fields: {"$module":"mms_vsa64_10130","CommandID":"D332948D-A7A9-4E07-B76C-253DCF6E17FB"}
Message: TOL: Failed to execute the command. Backup plan 'Entire machine to \\NAS\Backup\server2k16'
------------------------
Error code: 22
Module: 309
LineInfo: 0x8D165E86FB81959B
Fields: {"$module":"agent_protection_addon_vsa64_10130","CommandID":"D332948D-A7A9-4E07-B76C-253DCF6E17FB"}
Message: TOL: Failed to execute the command. Backup plan 'Entire machine to \\NAS\Backup\server2k16'
------------------------
Error code: 41
Module: 307
LineInfo: 0xE6792A5EE190DE2C
Fields: {"$module":"agent_protection_addon_vsa64_10130"}
Message: Failed to execute the command.
------------------------
Error code: 22
Module: 309
LineInfo: 0x8D165E86FB81959B
Fields: {"$module":"mms_vsa64_10130","CommandID":"F30407D6-601F-11E0-9C67-FF46DFD72085"}
Message: TOL: Failed to execute the command. Backup workflow
------------------------
Error code: 22
Module: 309
LineInfo: 0x8D165E86FB81959B
Fields: {"$module":"gtob_backup_command_addon_vsa64_10130","CommandID":"F30407D6-601F-11E0-9C67-FF46DFD72085"}
Message: TOL: Failed to execute the command. Backup workflow
------------------------
Error code: 1
Module: 80
LineInfo: 0x6DDB03E02A4503BE
Fields: {"$module":"mms_vsa64_10130"}
Message: Failed to retrieve parameter 'Caption'.
------------------------
Error code: 1002
Module: 20
LineInfo: 0xC523D9A02D03D662
Fields: {"$module":"mms_vsa64_10130"}
Message: 'CoCreateInstance' for 'CLSID_WbemLocator' failed.
------------------------
Error code: 65520
Module: 0
LineInfo: 0xBD28FDBD64EDB8FB
Fields: {"$module":"mms_vsa64_10130","code":"2147943418"}
Message: Illegal operation attempted on a registry key that has been marked for deletion
问题原因
管理员使用服务帐户登录到服务器进行交互式会话,然后注销后,通常会发生此问题。此活动强制在该帐户的配置文件中卸载注册表项。这种情况使密钥无法供将来使用,并且 Acronis Cyber Backup 无法访问它们。
有关详细信息,请参阅此Microsoft 支持文章
解决方法
禁用注销后卸载注册表项的 Windows 用户配置文件服务功能。为此,请按照下列步骤操作:
1.在受影响的服务器上打开组策略编辑器 (Gpedit.msc)
2.打开以下路径中的 UserProfiles 文件夹:计算机配置>管理模板>系统>用户配置文件
3.找到在用户注销时不强制卸载用户注册表设置,并将该设置更改为启用
4.重新启动 Acronis Managed Machine Service(开始 -> 运行 ->键入 services.msc ->在服务列表中找到 Acronis Managed Machine Service,右键单击它并选择重新启动)