#1118 Acronis Cyber Protect:在 Windows 上安装 Acronis 代理失败并显示 MSI 错误

 [公开]
icon佟裕在 2023-11-24 下午4:33 编写 ( icon佟裕在 2023-11-24 下午4:34 更新 <历史> )
  编辑(登录)
  收藏
  响应调查   响应调查

  主题

问题现象

1.您正在 Windows 上安装 Acronis 代理。
2.安装失败,MSI 代码为 1603。
安装程序 GUI 中的通用错误消息示例:
clip-20231124150402.png
完整的错误消息:

MSI (s) (4C:44) [09:33:58:012]: Doing action: SetArpInstallLocation
MSI (s) (4C:44) [09:33:58:012]: Note: 1: 2205 2:  3: ActionText 
Fin de l’action 09:33:58 : CostFinalize. Valeur renvoyée : 1.
MSI (s) (4C:44) [09:33:58:012]: PROPERTY CHANGE: Adding ARPINSTALLLOCATION property. Its value is 'C:\Program Files\BackupClient\'.
Début de l’action 09:33:58 : SetArpInstallLocation.
MSI (s) (4C:44) [09:33:58:012]: Doing action: CADataInitCA
MSI (s) (4C:44) [09:33:58:012]: Note: 1: 2205 2:  3: ActionText 
Fin de l’action 09:33:58 : SetArpInstallLocation. Valeur renvoyée : 1.
*MSI (s) (4C:1C) [09:33:58:012]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI4050.tmp, Entrypoint: CADataInit*
*Début de l’action 09:33:58 : CADataInitCA.*
CustomAction CADataInitCA returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Fin de l’action 09:34:10 : CADataInitCA. Valeur renvoyée : 3.
Fin de l’action 09:34:10 : INSTALL. Valeur renvoyée : 3.
Property(S): InstallMode = Typical
Property(S): UpgradeCode = {DAC56B69-1A5E-494D-92AE-A462FFB2A281}
Property(S): WINDOWS_INSTALLATION_TYPE = Server
Property(S): manufacturermenu = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Acronis\
Property(S): TARGETDIR = C:\Program Files\BackupClient\
Property(S): SYSTEMMONITORDIR = C:\Program Files\Common Files\Acronis\Drivers\SystemMonitor\
Property(S): FILEMONITORDIR = C:\Program Files\Common Files\Acronis\Drivers\FileMonitor\
Property(S): ALLUSERS = 1

问题原因

该错误是由以前的 Acronis 代理安装尝试或其他不相关软件的安装运行/尝试的剩余文件引起的。这是 Windows 环境中很少出现的项目。
另一个可能的原因是防病毒/反恶意软件可能会干扰对安装程序临时文件的访问。
这两种原因也有可能同时发生。

解决方法

1.从以下临时位置删除子文件夹和文件:

  • C:\Users\Administrator\AppData\Local\Temp\
  • C:\Windows\Installer\MSI.tmp,其中 是临时文件的自动生成的名称。

2.重新运行安装程序。

其他信息:

如果这不能解决问题,建议:

  • 联系Acronis中文支持
  • 尝试新安装时收集 ProcMon (PML)
  • 先压缩 PML,然后再将其上传到 Acronis 支持提供的 FTP
  • 提供命令 '.set' 输出结果

原文链接:https://kb.acronis.com/content/72336

 附加文件     - [1]


 添加评论