问题现象(介绍)
备份操作或对计算机应用备份计划失败,并显示以下信息:
Windows Error: (0x80070002) The system cannot find the file specified
0x2730016: Failed to add account in user profile.
仔细检查完整的错误信息,查找以下错误之一:
错误1
| error 0x40011: The specified file does not exist.
| line: 0xf35f747b3b21f916
| file: k:\7641\core\file\windows\winnt_dir.cpp:525
| function: winnt_dir::OpenFile
| function: OpenFileW
| path: \\?\C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\profiles\DEC92E32-D7CA-2543-24C7-0E8FF122F62F\lock
| $module: access_manager_vsa64_7641
完整的错误信息:
| error 0x2760002: Cannot modify user profile.
| line: 0x750572590d9bc3f4
| file: k:\7641\enterprise\managers\gtob\protection\supplementary\credentials_control.cpp:225
| function: Gtob::Gct::CredentialsControl::SelectPlanCredentials
| $module: agent_protection_addon_vsa64_7641
|
| error 0x273000d: Access violation in module 'agent_protection_addon.dll' at line '0x750572590d9bc3f4', executable: 'mms.exe'.
| line: 0xe839411589f18ba5
| file: k:\7641\enterprise\managers\access\impl\profile_vault_component.cpp:1644
| function: AccessManagement::ProfileVaultComponent::AddAccountToUserProfile
| $module: access_manager_vsa64_7641
|
| error 0x2730016: Failed to add account in user profile.
| line: 0x53cbdf900173a19c
| file: k:\7641\enterprise\managers\access\impl\persistent_storage_logic.cpp:943
| function: AccessManagement::Impl::PersistentStorageLogic::AddAccount
| ResourceType: location
| ResourceAddress: bsp://
| ProfileID: DEC96E32-D5CA-2543-2BC7-0E7FF192F62F
| $module: access_manager_vsa64_7641
|
| error 0x40011: The specified file does not exist.
| line: 0xf35f747b3b21f916
| file: k:\7641\core\file\windows\winnt_dir.cpp:525
| function: winnt_dir::OpenFile
| function: OpenFileW
| path: \\?\C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\profiles\DEC92E32-D7CA-2543-24C7-0E8FF122F62F\lock
| $module: access_manager_vsa64_7641
|
| error 0xfff0: The system cannot find the file specified
| line: 0xbd28fdbd64edb8f1
| file: k:\7641\core\common\error.cpp:307
| function: Common::Error::AddWindowsError
| code: 0x80070002
| $module: access_manager_vsa64_7641
错误2
| error 0x25e000b: Cannot open file.
| line: 0x2a0cf3e48ece3369
| file: k:\7048\enterprise\common\file_utils\source\file_io.cpp:46
| function: FileUtils::OpenFileI
| path: C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\config\preferred
| $module: access_manager_vsa64_7048
或者
| error 0x25e000b: Cannot open file.
| line: 0x2a0cf3e48ece3369
| file: k:\7048\enterprise\common\file_utils\source\file_io.cpp:46
| function: FileUtils::OpenFileI
| path: C:\ProgramData\Acronis\AMS\AccessVault\config\preferred
| $module: access_manager_vsa64_7048
完整的错误信息:
| error 0x2760002: Cannot modify user profile.
| line: 0x750572590d9bc3f4
| file: k:\7048\enterprise\managers\gtob\protection\supplementary\credentials_control.cpp:225
| function: Gtob::Gct::CredentialsControl::SelectPlanCredentials
| $module: agent_protection_addon_vsa64_7048
|
| error 0x273000d: Access violation in module 'agent_protection_addon.dll' at line '0x750572590d9bc3f4', executable: 'mms.exe'.
| line: 0xe839411589f18ba5
| file: k:\7048\enterprise\managers\access\impl\profile_vault_component.cpp:1644
| function: AccessManagement::ProfileVaultComponent::AddAccountToUserProfile
| $module: access_manager_vsa64_7048
|
| error 0x2730016: Failed to add account in user profile.
| line: 0x53cbdf900173a19c
| file: k:\7048\enterprise\managers\access\impl\persistent_storage_logic.cpp:943
| function: AccessManagement::Impl::PersistentStorageLogic::AddAccount
| ResourceType: location
| ResourceAddress: //192.168.109.22/e$/
| ProfileID: 07DB0F97-9D4F-2D9B-0349-C99737F8E07E
| $module: access_manager_vsa64_7048
|
| error 0x25e000b: Cannot open file.
| line: 0x2a0cf3e48ece3369
| file: k:\7048\enterprise\common\file_utils\source\file_io.cpp:46
| function: FileUtils::OpenFileI
| path: C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\config\preferred
| $module: access_manager_vsa64_7048
|
| error 0x40011: The specified file does not exist.
| line: 0xf35f747b3b21f78b
| file: k:\7048\core\file\windows\winnt_dir.cpp:130
| function: winnt_dir::OpenFile
| function: OpenFileW
| path: \\?\C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\config\preferred
| $module: access_manager_vsa64_7048
|
| error 0xfff0: The system cannot find the file specified
| line: 0xbd28fdbd64edb8f1
| file: k:\7048\core\common\error.cpp:307
| function: Common::Error::AddWindowsError
| code: 0x80070002
| $module: access_manager_vsa64_7048
如果您发现这些错误之一,请按照本文操作。否则,请联系安克诺斯技术支持。
错误1的解决方案
问题原因
您已在此计算机上重新安装了Acronis Cyber Backup,或从管理服务器中删除了该计算机并将其重新添加。结果,创建了重复的用户配置文件。
解决方法
该机制将在Acronis Cyber Backup 12.5的下一次更新中进行重新设计。
同时,手动删除重复的配置文件:
- 请注意错误消息中指定的配置文件(在上面的示例中:DEC92E32-D7CA-2543-24C7-0E8FF122F62F)。
- 在受影响的计算机上,打开C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\profiles\
- 在此文件夹中,您将找到2个配置文件:错误消息中指定的一个和另一个。注意另一个 GUID 。
- 停止Acronis Managed Machine Service:打开命令提示符,然后输入:
net stop mms
- 下载SQLite。
- 在命令提示符中,导航到保存SQLite的文件夹。使用cd命令。
- 输入以下命令:
sqlite3.exe C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\config\profiles.db3
- 输入以下命令:
其中是您在步骤3中记录的GUID。delete from PROFILES where ID='<GUID>';
- 按
Ctrl + Z
退出SQLite。 - 启动Acronis Managed Machine Service:
net start mms
错误2的解决方案
问题原因
与以前版本的更新有关的问题。
解决方法
如果文件夹中已存在“preferred”文件,请不要替换该文件,也不要应用任何其他解决方案,上报案件。
如果文件不在文件夹中:
- 停止MMS或AMS(请参阅错误消息)。
- 运行:
或"C:\Program Files\Acronis\UpgradeTool\upgrade_tool.exe" --workflow=mms
在Linux中:"C:\Program Files\Acronis\UpgradeTool\upgrade_tool.exe" --workflow=ams
或Acronis/UpgradeTool/upgrade_tool --workflow=mms
Acronis/UpgradeTool/upgrade_tool --workflow=ams
- 检查:
- 在Windows中:C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault 或C:\ProgramData\Acronis\BackupAndRecovery\AMS\AccessVault。
- 在Linux中:/var/lib/Acronis/BackupAndRecovery/MMS/AccessVault 或/var/lib/Acronis/AMS/AccessVault
查找包含“ticket”文件的所有文件夹并将其删除。
- 启动MMS或AMS。