如果您的虚拟机使用重复的BIOS UUID,则看不到所有现有的虚拟机。仅显示其中之一。要解决此问题,应在其中一台受影响的计算机中手动更改BIOS UUID
本文适用于:
Acronis Cyber Backup 11.7-从早期版本升级
Acronis Cyber Backup 12 / 12.5-从早期版本升级
问题现象
如果您的虚拟机使用重复的BIOS UUID,则看不到所有现有的虚拟机。仅显示其中之一。
以下步骤可能导致重复的BIOS UUID:
- 您可以使用vSphere克隆现有虚拟机;
- 现有的虚拟机使用其他备份软件进行复制;
- 您使用vCloud Director导入虚拟机;
- 使用vCloud中的模板创建虚拟机。
问题原因
Acronis Cyber Backup&Recovery 11.5在VMware中需要具有唯一的BIOS UUID,以便识别每台计算机。默认情况下,新安装的Acronis Cyber Backup&Recovery 11.5 / 11.7和更高版本的产品使用实例UUID方法,而其他安装或以前安装的升级则使用BIOS UUID方法。使用实例UUID方法将防止发生此问题。
解决方法
- 打开Windows注册表编辑器。转到开始->运行->regedit.exe;
- 导航到以下注册表路径:
在具有VMware Agent(Windows)的计算机上:
HKLM\Software\Acronis\VirtualWare\VMwareESXServer
在安装了Acronis Management Server的计算机上:
HKLM\Software\Acronis\AMS\Settings\VMwareESXServer
在具有虚拟设备/etc/Acronis/VirtualWare.config的ESX(i)主机上 - 创建一个新的密钥VMwareESXServer,并在其中添加一个新的DWORD(32位),其名称为UseInstanceUuid和值1。
值0启用BIOS UUID方法,值1启用实例UUID方法。 - 重新启动Acronis服务。
更多信息
新产品安装将使用实例UUID。升级的产品安装将继承UUID用法:
- 如果产品使用的是BIOS UUID,它将继续使用此方法。
- 如果产品使用的是实例UUID,它将继续使用此方法;
- 如果不存在该值,它将使用实例UUID方法。
- 从Acronis Management Server更新虚拟设备将保留最初使用的方法,并且不会被Acronis Management Server上定义的方法覆盖。
如果在升级/更新后出现孤立的虚拟机,请确保UseInstanceUuid值在代理和管理服务器上相同,并且根据要使用的UUID类型正确设置了该值。