现象
备份或其他操作失败并显示“The operation has timed out.”
活动详情:
Error 0x1350016: TOL: Failed to execute the command. Backup plan 'Test'
| line: 0x8d165e86fb81959b
| file: e:\306\enterprise\common\tol\command\command.cpp:461
| function: Tol::`anonymous-namespace'::MakeFailResult
| CommandID: D332948D-A7A9-4E07-B76C-253DCF6E17FB
| $module: mms_vsa64_12210
|
| error 0x1350016: TOL: Failed to execute the command. Backup plan 'Test'
| line: 0x8d165e86fb81959b
| file: e:\306\enterprise\common\tol\command\command.cpp:461
| function: Tol::`anonymous-namespace'::MakeFailResult
| CommandID: D332948D-A7A9-4E07-B76C-253DCF6E17FB
| $module: agent_protection_addon_vsa64_12210
|
| error 0x1330029: Failed to execute the command.
| line: 0xe6792a5ee190de27
| file: e:\306\enterprise\managers\gtob\protection\agent_engine\protect_command.cpp:213
| function: `anonymous-namespace'::ProtectCommand::SafeExecute
| $module: agent_protection_addon_vsa64_12210
|
| error 0x1350016: TOL: Failed to execute the command. Backup workflow
| line: 0x8d165e86fb81959b
| file: e:\306\enterprise\common\tol\command\command.cpp:461
| function: Tol::`anonymous-namespace'::MakeFailResult
| CommandID: F30407D6-601F-11E0-9C67-FF46DFD72085
| $module: mms_vsa64_12210
|
| error 0x1350016: TOL: Failed to execute the command. Backup workflow
| line: 0x8d165e86fb81959b
| file: e:\306\enterprise\common\tol\command\command.cpp:461
| function: Tol::`anonymous-namespace'::MakeFailResult
| CommandID: F30407D6-601F-11E0-9C67-FF46DFD72085
| $module: gtob_backup_command_addon_vsa64_12210
|
| error 0x1490002: Step 'Backup' has failed.
| line: 0x8edc81ea38fabaa3
| file: e:\306\enterprise\managers\gtob\backupers\backup_command\impl\backup_workflow_command.cpp:663
| function: `anonymous-namespace'::BackupWorkflowCommand::ProcessWorkflowSteps
| TraceLevel: 0x1
| StepType: 0x2
| $module: gtob_backup_command_addon_vsa64_12210
|
| error 0x1350016: TOL: Failed to execute the command. Tol::IsolateCommand
| line: 0x8d165e86fb81959b
| file: e:\306\enterprise\common\tol\command\command.cpp:461
| function: Tol::`anonymous-namespace'::MakeFailResult
| CommandID: 4504F8D4-2727-42AB-BB4F-A42EDBB790A0
| $module: mms_vsa64_12210
|
| error 0x12c000b: Failed to connect to the process.
| line: 0x2a46340236902188
| file: e:\306\enterprise\service\process\launcher\launcher.cpp:300
| function: `anonymous-namespace'::ServiceProcessControl::Connect
| $module: mms_vsa64_12210
|
| error 0x12c000c: The operation has timed out.
| line: 0x2a4634023690218a
| file: e:\306\enterprise\service\process\launcher\launcher.cpp:302
| function: `anonymous-namespace'::ServiceProcessControl::Connect
| $module: mms_vsa64_12210
问题原因
如果初始化磁盘系统的处理由于超时而失败,则会发生此错误。例如,如果存在连接的USB驱动器,SD卡或其他具有较长初始化时间的存储器,则可能发生此问题。在开始为备份写入数据之前,代理应初始化包含所有已连接存储设备的磁盘系统。如果这些设备中的任何一个未在15分钟内初始化,您将收到错误消息。
解决方法
方法1
如果计算机上连接了任何USB驱动器/ SD卡-请更新这些存储设备的驱动程序。如果驱动程序不是最新的,则可能导致初始化时间变慢并导致此错误。如果您不使用USB驱动器/ SD卡作为备份计划的源或目标,但已将它们连接到计算机,则将其拔下。
如果未正确卸载USB驱动器,并且操作系统的行为好像仍在连接(可能导致问题重现),则也可能出现这种情况。执行以下操作,检查磁盘是否已正确拔出:
1.打开“磁盘管理”(按Win + R,输入diskmgmt.msc,然后单击“确定”),然后检查是否有任何未插拔的磁盘仍显示为已连接。
2.运行Acronis系统报告。该工具的输出是包含诊断信息的存档。在其中找到磁盘报告,将其打开并检查是否仍然检测到任何USB磁盘。请参见下面的示例:
如果您没有将USB / SD卡连接到计算机,则该错误也可能表明其中一个磁盘响应缓慢。请运行磁盘供应商提供的磁盘检查器实用程序,以检查其运行状况。
方法2
延长service_process.exe.它的默认值是15分钟(从版本12210开始的Windows代理)或5分钟(版本12210之前的Windows代理,以及Linux和Mac的代理)。如果遇到问题,建议将默认超时时间增加到30分钟。
1.在安装了Acronis代理的Windows计算机上,转到开始->搜索->输入regedit.exe,然后按Enter。
- 找到此键:HKEY_LOCAL_MACHINE\SOFTWARE\Acronis\BackupAndRecovery\CommonComponents\ServiceProcess\Settings\
- 创建一个新的32位DWORD,名为StartTimeout,值例如1800000,基数:十进制
(!)名称是区分大小写的。注意大小写。名称是StartTimeout;
(!)该值以毫秒为单位。例如。 30分钟为1800000(30 x 60 x 1000 = 1800000);
2.对于Linux系统,打开/etc/Acronis/BackupAndRecovery.config。
- 找到
<key name="ServiceProcess"> <key name="Settings>
- 在“设置”部分中添加以下值:
(!)增加默认超时也将导致完成备份的时间增加,如果您不想增加默认超时,请考虑检查解决方法#1<value name="StartTimeout" type="Tdword"> "300000" </value>