现象
活动(备份,验证等)失败,提示以下错误:
Windows error: (0x80070570) The file or directory is corrupted and unreadable
Error code: 2064
Module: 23
LineInfo: 0xA61565B622786E4A
Fields: {"Path":"E:/Backup/","$module":"disk_bundle_vsa64_12960"}
Message: Failed to enumerate directory 'E:/Backup/'. It may be corrupted or does not exist. Please check the disk for errors.
------------------------
Error code: 1
Module: 4
LineInfo: 0xF35F747B3B21FC44
Fields: {"function":"NtQueryDirectoryFile","$module":"disk_bundle_vsa64_12960","path":"\\\\?\\E:\\Backup\\"}
Message: Error occurred while reading the file.
------------------------
Error code: 65520
Module: 0
LineInfo: 0xBD28FDBD64EDB8F1
Fields: {"code":"2147943792","$module":"disk_bundle_vsa64_12960"}
Message: The file or directory is corrupted and unreadable
问题原因
最可能的原因是文件系统损坏或磁盘错误。
前提
不要使用文件备份来备份系统文件夹,例如:C:\Windows或系统卷信息文件夹,它们应该用磁盘级备份保护(参见产品手册)。文件级备份不足以恢复操作系统。如果您计划保护用户数据,例如文档和个人文件,请选择“文件备份”。
故障排除
1.确定哪个磁盘产生错误。
打开错误消息(单击“详细信息”)并找到“路径”,例如,找到”字段“。示例:Fields: {"Path":"E:/Backup/","$module":"disk_bundle_vsa64_12960"}
2.修复受影响卷上的文件系统。使用Acronis磁盘报告检查文件系统的状态和/或检查Windows事件日志是否有硬件问题(有关更多信息,请参阅本文),或使用硬件制造商提供的诊断工具。
如何通过Acronis磁盘报告查看磁盘健康性
1.运行Acronis系统报告。参见Acronis系统报告
2.该工具的输出是具有诊断信息的报告。在其中找到磁盘报告并检查是否存在错误。
C列代表完整分区检查状态
c - 意味着没有错误
e - 意味着找到了错误
w - 表示警告
如果Acronis Disk Report显示您尝试备份的驱动器的状态为E或W,或Windows事件日志显示与某个磁盘/分区相关的错误,然后建议检查分区以获取错误和修复。您可以Windows本机检查磁盘实用程序:
- 确保您有一个健康的机器备份。如果没有,您可以使用Acronis可启动媒体创建一个。
- 启动命令提示符(start - >运行 - > cmd - >右键单击并选择以管理员身份运行)并输入以下命令:
chkdsk <disk letter>: /r /f
其中是您需要检查的分区字母,例如:chkdsk E: /r /f - 请注意,检查C:驱动器可能需要您重新启动计算机。
3.如果磁盘包含来自之前的chkdsk尝试的残差数据,也可能发生此问题。此类文件位于Found.000 / File00000000中。根文件夹的chk文件夹。错误消息:
Error code: 65520
Fields: {"$module":"disk_bundle_vsa64_22750","code":2147943792,"function":"CreateFileW","path":"\\\\?\\GLOBALROOT\\Device\\HarddiskVolumeShadowCopy28\\found.000\\file00000000.chk"}
Message: The file or directory is corrupted and unreadable.
从驱动器中删除文件或found.000文件夹。重要的提示:此文件夹的目的是保持潜在恢复文件,您可先检查其内容,删除文件夹后,将不会有任何可能查看和恢复其内容。有关详细信息,请参阅Microsoft解答中相关讨论。
收集更多信息
如果建议的步骤没有解决这个问题,从受影响的代理机器收集Acronis系统报告,并参考以下文章联系Acronis客户中心: