问题现象
- 您使用单独的MS SQL Server数据库用于Acronis Management Server;
- 在装有Management Server的计算机和其他计算机上禁用了TLS 1.0;
- Management Server上的操作失败。管理服务器日志(%ProgramData%/Acronis/AMS/logs/ManagementServer.0.log))包含以下错误:
| error 0x1290021: 01000: [Microsoft][ODBC SQL Server Driver][DBNETLIB]SSL Security error [Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (SECDoClientHandshake()).
问题原因
过时的ODBC SQL Server驱动程序。
解决方法
更新SQL Server ODBC驱动程序并更改Management Server配置:
- 下载最新的SQL Server ODBC驱动程序,例如,您可以在此处找到SQL Server 2017的最新ODBC驱动程序;
- 在运行Management Server的计算机上安装下载的SQL Server ODBC驱动程序;
- 安装驱动程序后,转到控制面板->管理工具-> ODBC数据源(64位);
- 在“ OBDC数据源管理器” 窗口中,转到“驱动程序”选项卡,并记下驱动程序的名称;
- 打开 C:\ProgramData\Acronis\AMS\mssql\dml_mssql.config 进行编辑;
查找以下字符串:
<parameter name="driver"> SQL Server</parameter>
参数值可以是“ SQL Server”或其他值。
将所有出现的 SQL Server </ parameter>替换为%NAME_OF_NEW_SQL_SERVER_ODBC_DRIVER%</ parameter>,其中%NAME_OF_NEW_SQL_SERVER_ODBC_DRIVER%-在步骤4中获得的新ODBC驱动程序的名称;
- 保存配置文件并重新启动Acronis Management Server服务。