问题现象
- 您已经配置了VMware代理程序(Windows 或Appliance)连接到一台 vCenter/ESX(i) 主机;
- 在恢复或物理转换到虚拟后,某些虚拟机没有显示在备份控制台中。
问题原因
当前的 Acronis Cyber Backup 产品使用 VMware“InstanceUUID”属性来识别每台虚拟机,如果一台或多台机器使用相同的 InstanceUUID,那么只有一台机器会显示在备份控制台中。
如果 Acronis 产品是从旧版本升级的,它可能使用 BIOS UUID 进行 VM 识别,您可以将 BIOS UUID 识别方法更改为 InstanceUUID 方法:有关说明,请参阅此文章。
解决方法
更改其中一台计算机的 InstanceUUID 以使其显示在备份控制台中,这可以通过直接连接到主机或通过 vCenter来完成。
直接连接到主机:
- 打开 vSphere;
- 转到帮助 -> 工具和链接-> 管理对象浏览器(如果需要,请按启用);
- 然后在地址中输入:https:///mob 并使用主机 root 凭据登录;
找到ServiceContent 并点击content;
找到 rootFolder 并点击 ha-folder-root;
找到 childEntity 并点击 ha-datacenter;
找到 datastoreFolder 并点击 ha-folder-datastore;
找到 childEntity 并点击
"<GUID>" (<datastorename>)
;- 查找vm 并检查带有名称的虚拟机列表;
找到必要的虚拟机并按分配的<编号>;
找到 config 并点击 config;
找到 instanceUuid 参数并检查字符串:
- 如果字符串没有任何值,则设置一个随机的唯一 GUID;
- 如果字符串有值,但 VM 在控制台中仍然不可见,请将 GUID 更改为任何其他值。
如果值为空,请按照以下步骤更改 GUID 或指定新的 GUID:
- 返回
- 找到 ReconfigVM_Task 并向下滚动到带有 instanceUuid 的部分。
根据您的环境,此参数名称中可能有不同的字母大写:InstanceUUID、instanceUuid 等。运行查询时,请保持环境中的变量不变,即使本文中的屏幕截图或命令显示不同的大写/小写字母。 此参数区分大小写。
- 删除除以下部分以外的值字段的内容:
- 添加 GUID 号并运行以下查询:
<spec>
<InstanceUUID>[GUID]</InstanceUUID>
</spec>
以下列方式代替 GUID 放置 ID:abcdefgh-1234-ijkl-5678-mnopqrstuvws
例子:
<spec>
<InstanceUUID>529853de-346c-6685-496e-6b6a9f61c57b</InstanceUUID>
</spec>
- 点击 Invoke Method 设置新的 UUID
通过 vCenter 连接:
- 打开 Web 浏览器并输入https:///mob并使用管理员凭据登录;
找到 ServiceContent 并点击 content;
找到 rootFolder 并点击 ;
找到 childEntity 并点击 ;
找到 datastoreFolder 并点击 ;
查找vm 并检查带有名称的虚拟机列表;
找到必要的虚拟机并按分配的<编号>;
找到 config 并点击 config;
找到 instanceUuid 参数并检查字符串:
- 如果字符串没有任何值,则配置一个随机的唯一 GUID;
- 如果字符串有值,但 VM 在控制台中仍然不可见,请将 GUID 更改为任何其他值。
如果值为空,请按照以下步骤更改 GUID 或指定新的 GUID:
- 返回
- 找到ReconfigVM_Task并运行以下查询:
<spec>
<InstanceUUID>[GUID]</InstanceUUID>
</spec>
以下列方式代替 GUID 放置 ID:abcdefgh-1234-ijkl-5678-mnopqrstuvws
例子:
<spec>
<InstanceUUID>529853de-346c-6685-496e-6b6a9f61c57b</InstanceUUID>
</spec>
- 点击 Invoke Method