问题现象
当从一台由已安装Acronis Backup agent的操作系统模板部署一台计算机后,计算机可以成功注册,但无法出现在Acronis备份控制台的设备列表中。
原因
由于新部署的计算机的MachineID与Acronis 备份控制台中现有的计算机MachineID重复,导致只能有一台计算机出现在设备列表中。
处理方案:
在模板中更改MachineID,使其每次部署时都生成新的MachineID,步骤如下:
1.准备计算机模板(安装guest os和所需的应用程序)
2.将Acronis Backup agent 安装到模板中
3.停止Acronis Managed Machine Service (net stop mms)
4.清除软件注册表值或软件配置项
适用于Windows的说明
在计算机上打开注册表编辑器:“开始”>“运行”>“regedit”
导航到以下位置:
HKLM\Software\Acronis\BackupAndRecovery\Settings\MachineManager
并删除以下子项的值
- MMSCurrentMachineID
- InstanceID
适用于macOS的说明
导航到以下位置:
/Library/Application Support/Acronis/Registry/BackupAndRecovery.config
删除以下值
- InstanceID
- MMSCurrentMachineID
适用于Linux的说明
导航到以下位置:
/etc/Acronis/BackupAndRecovery.config
删除以下值
- InstanceID
- MMSCurrentMachineID
5.从“设置”->“代理”中将计算机从管理服务器中删除。 这一步是用来清理第一次注册的原始id,以便从同一模板部署的其他计算机实例在Acronis Backup中不会产生重复项:
6.模板准备完成。
现在,从模板配置新的计算机实例时,必须执行以下步骤才能在管理服务器上注册备份代理:
- 启动Acronis Managed Machine service服务 (net start mms)
- 通过register_agent.exe实用程序在管理服务器上注册代理(有关所有类型代理的说明,请参见 https://kb.tieten.cn/open.knowledge/view/17 ):
- Register_agent.exe –o register –a [管理服务器的地址]。请参阅QA lab的测试环境示例(10.250.193.191是管理服务器的地址):