#691 Acronis Cyber​​ Protect Cloud、Acronis Cyber​​ Protect 15:无法启动 MMS 服务,错误“错误 0x30002:无法绑定”。

iconRemoved User在 2022-4-11 下午4:00 编写
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问题现象

您想在管理服务器中使用 Acronis Agent 注册计算机。注册失败,您检查 Acronis Managed Machine 服务并看到它已停止。

当您尝试启动服务时,您会看到此错误(记录在 Windows 事件日志中):

中文提示:
错误 0xb9000b:无法初始化网络模块。
| 跟踪级别:错误
| 行:0xb957662f70a242f 
| 文件:e:\327\enterprise\service\impl\server.cpp:678 
| 函数:Core::ServerImpl::StartNetworkServer 
| $模块:mms_vsa64_12420 
| 
| 错误 0x30002:无法绑定
| 行:0xe6f03fbb500414fa 
| 文件:e:\327\enterprise\common\async_ipc\async\io_base_libevent.cpp:371 
| 函数:AsyncIpc::Libevent::IoBase::Activate 
| $模块:asyncipc_vsa64_12420

英文提示:
Error 0xb9000b: Failed to initialize network module.
| trace level: error
| line: 0xb957662f70a242f
| file: e:\327\enterprise\service\impl\server.cpp:678
| function: Core::ServerImpl::StartNetworkServer
| $module: mms_vsa64_12420
|
| error 0x30002: CannotBind
| line: 0xe6f03fbb500414fa
| file: e:\327\enterprise\common\async_ipc\async\io_base_libevent.cpp:371
| function: AsyncIpc::Libevent::IoBase::Activate
| $module: asyncipc_vsa64_12420

问题原因

Acronis Agent 所需的端口 9850 被其他软件使用。

解决方法

检查哪个软件使用端口 9850。

在 Windows 中:

  1. 运行:
    netstat -ant | findstr 9850
    
    查找监听9850的进程的PID
  2. 运行:
    tasklist /fi "pid eq <PID>
    
    其中 是在步骤 1 中找到的进程 ID。

在 Linux 中:

  1. 运行:
    netstat -tanp | grep 9850
    
    查找监听9850的进程的PID
  2. 运行:
    ps -p <PID> -o comm=
    
    其中 是在步骤 1 中找到的进程 ID。

从 Acronis Cyber​​ Cloud 21.01 (Build 26226) 和 Acronis Cyber​​ Protect 15 Build 26172 开始,可以在安装代理后更改端口 9850。

  1. 打开以下文件进行编辑:
    C:\ProgramData\Acronis\BackupAndRecovery\MMS\user.config
    
  2. 在network section添加以下行:

    <async_ipc_mms_port>9850</async_ipc_mms_port>
    

    clip-20220411145553.png

  3. 根据您的需要将9850更改为其他的端口,并将更改保存到文件中。

  4. 重新启动Acronis Managed Machine Service。

对于早期版本,无法更改 Acronis Agent 的此端口,请更改第三方应用程序的设置以使用其他端口。


原文链接:https://kb.acronis.com/content/63212

 附加文件     - [1]


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