#802 Acronis Cyber​​ Backup、Acronis Cyber​​ Protect:无法识别计算机上的Hyper-V 角色

iconRemoved User在 2022-8-10 上午11:53 编写
  编辑(登录)
  收藏
  响应调查   响应调查

  主题

问题现象

  • 您正在计算机上安装Agent for Windows和Agent for Hyper-V
  • 无法在计算机上安装Hyper-V 代理程序,因为无法识别Hyper-V角色

问题原因

可能是环境问题。

故障排查

  1. 确保 Hyper-V 服务正在运行。请参阅此Windows 文章
  2. 检查 WMI 是否正常工作。

如何检查WMI是否正常工作

  1. 下载并运行此工具以检查是否能检测到 Hyper-V。
  2. 使用wmic运行以下 wmi 查询:
    # wmic /namespace:\\root\cimv2 path win32_optionalfeature where "installstate= 1 and Name='Microsoft-Hyper-V'" get *
    # wmic /namespace:\\root\cimv2 path win32_optionalfeature where installstate=1 get *
    
  3. 使用wbemtest运行以下命令 :
    # select * from win32_optionalfeature where installstate= 1 and Name='Microsoft-Hyper-V'
    
    • 如果 WMI 损坏,将显示类似于此的红色错误:
      clip-20220810105024.png

    • 如果 WMI 工作正常,输出将显示有关 Hyper-V 服务的信息:
      clip-20220810105050.png

clip-20220810105100.png 必须修复 WMI 问题才能使 Acronis 产品正常工作。我们建议联系 Microsoft 支持以获取有关 WMI 错误的帮助。


原文链接:https://kb.acronis.com/content/70910


 添加评论