问题现象
- 您正在计算机上安装Agent for Windows和Agent for Hyper-V
- 无法在计算机上安装Hyper-V 代理程序,因为无法识别Hyper-V角色
问题原因
可能是环境问题。
故障排查
- 确保 Hyper-V 服务正在运行。请参阅此Windows 文章
- 检查 WMI 是否正常工作。
如何检查WMI是否正常工作
- 下载并运行此工具以检查是否能检测到 Hyper-V。
- 使用wmic运行以下 wmi 查询:
# wmic /namespace:\\root\cimv2 path win32_optionalfeature where "installstate= 1 and Name='Microsoft-Hyper-V'" get * # wmic /namespace:\\root\cimv2 path win32_optionalfeature where installstate=1 get *
- 使用wbemtest运行以下命令 :
# select * from win32_optionalfeature where installstate= 1 and Name='Microsoft-Hyper-V'
如果 WMI 损坏,将显示类似于此的红色错误:
如果 WMI 工作正常,输出将显示有关 Hyper-V 服务的信息:
必须修复 WMI 问题才能使 Acronis 产品正常工作。我们建议联系 Microsoft 支持以获取有关 WMI 错误的帮助。