问题现象
1.在启动Managed Machine服务时,依赖于它的Acronis Agent Core服务无法启动,出现以下错误信息:
中文日志:
机器上的mms.exe无法启动。启动该服务失败:
在 "本地机器 "上的 Аcronis Managed Machine服务 未能启动。
英文日志:
The mms.exe on the machine cannot be started. Starting the service fails with:
The „Аcronis Managed Machine Service” on “Local machine” failed to start
或
中文日志:
Managed Machine服务,Acronis Agent Core服务没有及时回答启动或控制请求
英文日志:
Managed Machine Service, Acronis Agent Core Service did not answer the start or control request in a timely fashion
2.受影响机器上的事件查看器日志显示,当试图启动Acronis Agent Core 服务时,服务控制管理器报告事件7001(错误)。
3.C:\ProgramData\Acronis\Agent\varlog\aakore下的aakore.log显示以下错误:
04T13:22:11.539+02:00", "level": "error", "msg": "start service: reading service info: yaml: control characters are not allowed" }
问题原因
Acronis 代理程序的一个配置文件被损坏了。
解决方法
需要重新创建配置文件来解决这个问题:
禁用Acronis Active Protection服务,以便能够重新创建配置文件:
在应用于问题中涉及代理的所有保护计划中禁用Acronis Active Protection服务:
在受影响的代理上,通过services.msc停止Acronis Active Protection Service。
- 在受影响的代理上,通过任务管理器杀死进程 "active_protection_service.exe"。
检查位于 "C:\ProgramData\Acronis\Agent\var\aakore "的以下文件的内容:
host-alias.yaml (C:\ProgramData\Acronis\Agent\var\aakore) roles.yaml (C:\ProgramData\Acronis\Agent\var\aakore) aakore.yaml (C:\ProgramData\Acronis\Agent\etc) aakore.info (C:ProgramData\Acronis\Agent\var\run\aakore)
- 如果其中一个文件是空的,请删除它并重新尝试启动 Acronis Managed Machine Service。
- 受影响的文件应在服务启动时自动重新创建。
- 打开重新创建的文件,检查是否有任何配置数据被写入其中。
更多信息
如果在上述步骤1中提到的禁用Acronis Active Protection服务有问题,请尝试以下方法之一: