本文适用于: Acronis Cyber Protect 15
现象
试图将一个代理端注册到保护控制台(管理服务器)时
注册失败,(如果试图取消注册代理,也会失败)。当检查 MMS 日志时,会看到以下错误:
[RestApi][AgentRegistration] status: manual unregister required, code: 409, reason: 'Registration of client failed: {"domain":"AccountServer","reason":"ReasonClientAlreadyRegistered","context":{"client_id":"A180B7F6-5E8D-4677-AB05-2586B3677590"},"debug":{"msg":"Client with same ID is already created"},"code":"ReasonClientAlreadyRegistered"}'
尝试手动注册代理端失败了,并提示"Agent is already registered。请在 Cyber Protection 控制台取消注册代理" 。
试图手动注册代理时失败了,并提示"ID 为[代理端ID号]的代理端已经在不同的单元中注册"。
原因
如果机器在注册后被迁移到另一个管理服务器上,或者机器是从一个不同的、已经注册的机器的镜像中恢复的,就可能出现这样的问题。
必须把它和机器 ID 一起完全删除(通常卸载过程中不会删除)。
解决方案:
- 登录到有问题的机器上
卸载代理程序。确保在卸载过程中选中 "删除日志和配置设置 "复选框。
. 从机器上删除旧的ID:
Windows 下的操作方法
在机器上打开注册表编辑器: 开始 > 运行 > regedit
导航到以下键位:
HKEY_LOCAL_MACHINE\Software\Acronis\BackupAndRecovery\Settings\MachineManager
删除以下子键- InstanceID
- MMSCurrentMachineID
macOS 下的操作方法
从/Library/Application Support/Acronis/Registry/BackupAndRecovery.config中删除 InstanceID 和MMSCurrentMachineID 值
Linux 下的操作方法
从/etc/Acronis/BackupAndRecovery.config 中删除 InstanceID 和 MMSCurrentMachineID 值。
使用最新的安装程序,再次安装代理程序。
找到重新安装代理程序后产生的新的 MMSCurrentMachineID (如果不执行重新安装,直接执行第3步后重启MMS服务,将重新生成MMSCurrentMachineID)
停止 Acronis Agent Core Service (aakore)
打开 reg.yml 进行编辑:
- Windows: C:\ProgramData\Acronis\Agent\var\aakore\reg.yml
- Linux: /opt/acronis/var/aakore/reg.yml
- macOS: /Library/Application Support/Acronis/Agent/var/aakore/reg.yml
在 oauth - id 和 oauth - client - id 部分添加新的 MMSCurrentMachineID
如果使用的15 U6(35979)以后的版本,需要修改第7步中aakore 目录下的reg.yml 和 oauth.yml 文件将id替换为新的id。
reg.yml
oauth.yml保存更改并关闭文件。启动aakore服务。
如果这还不能解决问题,在联系技术支持部门之前,请从受影响的代理端机器上收集一份新的系统报告。